[PD] alsa and etch udev

B. Bogart ben at ekran.org
Thu May 4 17:30:08 CEST 2006

Hey all,

I've tried getting this resolved on the debian-user list, but I'm not
really getting anywhere, so I'm trying here since I know a lot of you all
run alsa and debian.

So I was having some weird bugs with gnome, like nautalis crashing
intermitently, and my stickies getting all screwed up, so I thought I
would resolve that by installing the gnome-desktop-environment from etch.

The good news is now gnome actually works as expected.

The bad news is that both sound, and my bttv capture card are no longer
working. Looks like gnome-desktop-environment wants gnome-volume-manager,
which wants hal, which wants a newer udev. Alas it seems the newer udev is
not working with my sound card or my bttv capture card. This is my guess
anyhow. Note I did not change the kernel.

First video:

I used to have /dev/video0, /dev/video1, /dev/video2 The first two are my
cx88xx cards, which work in linux, not in Gem. the third was my winTV bttv
card (Thanks Chris K!). Now with udev 0.086-1 (it was version 0.056-3
before) /dev/video2 is missing. I'm trying to figure out how to create a
udev rule for the bttv before I try and downgrade all my gnome stuff to
sarge, which I think will cause other problems I don't expect.

Sound (asla)

Sound was working fine with OSS before, so when it did not work after the
upgrade I thought I would try ALSA.

So I installed alsa (apt-get install alsa-base alsa-utils)

I run alsaconf:

version 1.0.10


Following card(s) are found on your system
 via82xx                          VIA Technologies, Inc. VT8233/A/8


Do you want to modify /etc/modprobe.d/sound
(and /etc/modprobe.conf if present)?


OK, sound driver is configured.

bbogart at insitu:~$ sudo /usr/sbin/alsaconf
Unloading ALSA sound driver modules: snd-seq-dummy snd-seq-oss
snd-seq-midi snd-seq-midi-event snd-seq snd-via82xx snd-ac97-codec
snd-pcm-oss snd-mixer-oss snd-pcm snd-timer snd-page-alloc snd-mpu401-uart
snd-rawmidi snd-seq-device.
Building card database...

Running update-modules...
Loading driver...
Setting default volumes...
Saving the mixer setup used for this in /var/lib/alsa/asound.state.
/usr/sbin/alsactl: save_state:1163: No soundcards found...


 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

Note the "/usr/sbin/alsactl: save_state:1163: No soundcards found..." part.

I can even run /dev/sndstat (or was that OSS and not ALSA?)

bbogart at insitu:~$ cat /dev/sndstat
Sound Driver:3.8.1a-980706 (ALSA v1.0.9b emulation code)
Kernel: Linux insitu 2.6.13-ck5 #1 Thu Sep 22 10:31:48 EDT 2005 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
VIA 8237 with ALC850 at 0xe800, irq 217

Audio devices:
0: VIA 8237 (DUPLEX)



7: system timer

0: Realtek ALC850 rev 0

When I try and change the mixer volume I get:

alsamixer: function snd_ctl_open failed for default: No such device

So what devices in /dev do I need to create udev rules for?

Does anyone happen to have udev rules for 0.086-1 for my via82xx and/or
bttv cards?

Maybe I should email the udev (etch) maintainer...?


(Note the bttv part is more important in the short term, but I'd obviously
like to get both sound and that working.)

Thanks all,


More information about the Pd-list mailing list