[PD] osc objects

Hans-Christoph Steiner hans at eds.org
Mon May 8 15:33:49 CEST 2006

On May 7, 2006, at 6:56 AM, Mathieu Bouchard wrote:

> On Thu, 27 Apr 2006, Hans-Christoph Steiner wrote:
>>> osc/route
>>> osc/pack
>>> osc/unpack
>> I think these should be more descriptive.  They don't work exactly  
>> the same as
>> the core versions, so they should have different, but similar, names.
> Why should namespaces exist if they don't solve name conflicts?

Ok, to follow this logic, we should stop coming up with new names for  
objects.  All libraries will use letters for object names starting at A.


Why come up with new names if you don't have to? :-P

>> The suffix is fine, but it should be consistent across objects in  
>> the lib,
>> like:
>> [osc/packOSC]
>> [osc/unpackOSC]
>> [osc/routeOSC]
> those names all contain "osc" twice. if the latter "OSC" can't be  
> removed,
> then why not removing the leading "osc/" ?

Because if you do this:

[import osc]


A fundamental idea in programming is to name things descriptively so  
you can easily read the code.  Just because we can reuse the same  
names, doesn't mean we should.  The object name should represent what  
it does as clearly and compactly as possible.



I spent 33 years and four months in active military service and  
during that period I spent most of my time as a high class muscle man  
for Big Business, for Wall Street and the bankers.
                                             - General Smedley Butler

More information about the Pd-list mailing list