[PD] M-audio Quattro not working with PD anymore

kristof lauwers pd at kristoflauwers.domainepublic.net
Fri May 26 15:46:47 CEST 2006


I'm having strange problems with my M-audio Quattro card (on an Acer 
travelmate laptop, WinXP).
When i select ASIO from  the media menu, i get the popup window from where 
i can choose the device and settings, but if i select the M-Audio and click 
ok, i get immediately "audio I/O stuck... closing audio" and the popup 
window doesn't disappear (not when i press ok, or cancel and even not when 
i click the cross in the top left corner).  I tried it with pd-0.39-2 and 
with pd-0.37-4, with the native drivers of M-audio and with Asio4All and 
each time got the same behaviour.
When i try the M-audio card with the normal MME drivers, i also get the 
"audio I/O stuck" message, but the popup window does disappear.
PD with the internal soundcard works fine (without asio drivers)
Other programs do work fine with the Quator and asio drivers
The strange thing is that, on the same machine, PD used to work with that 
soundcard (although i had problems when i put -asio in the startup flags - 
see http://lists.puredata.info/pipermail/pd-list/2006-04/037674.html ) and 
no new hardware has been installed since the last time i worked with pd.. 
(also i don't allow windows updates)

any ideas on what's going wrong and how to solve it?

many thanks,



kristof.lauwers at logosfoundation.org


More information about the Pd-list mailing list