[PD] M-audio Quattro not working with PD anymore

kristof lauwers pd at kristoflauwers.domainepublic.net
Mon May 29 10:34:45 CEST 2006

hi again,

replying to myself..

This morning i had the genius idea (inspired by previous experiences with 
my USB memory stick) of trying to plug in the M-Audio Quattro in another 
USB slot, and gues what.. everything's working fine now!
So it looks like the problem was with the soundcard rather then with PD. 
Still it's strange that the card was working fine with other software.

I find it intriguing how the soundcard first worked, then stopped doing so 
(without any hardware changes), now is working again just by plugging it 
into another slot (while i had tried uninstalling it and reinstalling it 
before, but in the same slot!) - anyone has some insight on how this can 
happen? (guess i don't have to mention my OS anymore. for completeness: 
yes, it's WinXP :-/)



At 03:46 PM 5/26/2006, you wrote:

>I'm having strange problems with my M-audio Quattro card (on an Acer 
>travelmate laptop, WinXP).
>When i select ASIO from  the media menu, i get the popup window from where 
>i can choose the device and settings, but if i select the M-Audio and 
>click ok, i get immediately "audio I/O stuck... closing audio" and the 
>popup window doesn't disappear (not when i press ok, or cancel and even 
>not when i click the cross in the top left corner).  I tried it with 
>pd-0.39-2 and with pd-0.37-4, with the native drivers of M-audio and with 
>Asio4All and each time got the same behaviour.
>When i try the M-audio card with the normal MME drivers, i also get the 
>"audio I/O stuck" message, but the popup window does disappear.
>PD with the internal soundcard works fine (without asio drivers)
>Other programs do work fine with the Quator and asio drivers
>The strange thing is that, on the same machine, PD used to work with that 
>soundcard (although i had problems when i put -asio in the startup flags - 
>see http://lists.puredata.info/pipermail/pd-list/2006-04/037674.html ) and 
>no new hardware has been installed since the last time i worked with pd.. 
>(also i don't allow windows updates)
>any ideas on what's going wrong and how to solve it?
>many thanks,
>kristof.lauwers at logosfoundation.org
>PD-list at iem.at mailing list
>UNSUBSCRIBE and account-management -> 

More information about the Pd-list mailing list