[PD] mp3cast~ again

Richard Lewis richardlewis at fastmail.co.uk
Mon Feb 19 17:15:07 CET 2007

On Monday 19 February 2007 16:03, you wrote:
> Richard Lewis wrote:
> > Hey there,
> >
> > I'm trying to use mp3cast~ with Icecast 1.
> stupid me, but why are you using icecast-1 instead of icecast-2 ?

Its another Debian problem: the icecast2 package in Debian is ogg only.

> i might be totally wrong here, but to my knowledge, icecast stores
> passwords in plaintexts.
In Debian, icecast is compiled with encrypted passwords option.

> i think(! without reading the code), that following is happening:
> the "passwd" message stores the password in [mp3cast~] for later use.
> when you send it the [connect( message, it will use the previously
> stored password to connect to the server.
> so in this case it is _very important_ that you first send the [passwd(
> message and then send the [connect( message (else [mp3cast~] would try
> to connect to the server with an empty/default password)
OK, I've verified that its not a password problem now. The mp3cast~ 
documentation doesn't seem to mention this.

BTW, thanks for your reply regarding the -nogui option and setting dsp 1. I've 
just read it on the PD-list archive (as I seem to have intermittent mail 
delivery from PD-list!) and added it to my patch. Its obviously important, 
but I still can't connect to my mp3 streams :-(

Richard Lewis
Sonic Arts Research Archive
JID: ironchicken at jabber.earth.li

More information about the Pd-list mailing list