[PD] [Gem]: [pix_texture] doesn't work

IOhannes m zmoelnig zmoelnig at iem.at
Wed Feb 21 16:42:57 CET 2007


Roman Haefeli wrote:

> my version of gem is:
> GEM: ver: 0.91-cvs
> GEM: compiled: Nov 30 2006

so you have not changed Gem but you have updated your driver and now it
doesn't work any more?

> i am on ubuntu dapper with the fglrx-driver from the ubuntu-repository.
> it worked in earlier days and i did not recompile gem since then. i
> tried to recompile a checkout from today,  but when gem is loaded during
> pd-startup, i get:
> /usr/local/lib/pd/extra/Gem.pd_linux: /usr/local/lib/pd/extra/Gem.pd_linux: undefined symbol: glUniform2i
> (can i avoid this by disabling a certain switch in ./configure?)

yes, finally there is!
use "./configure --with-glversion=1.5"
or - even better - get drivers that provide header-files which match.

> all other apps that i have installed and use opengl (armagetron,
> blender, mplayer -vo gl) work without any problems and are able to show
> textures. gem is the only app, that doesn't work as expected. but when
> start X without dri enabled, [pix_texture] works. 

does the rest of Gem work or is it just the textures?

in any case, please file a bug-report at http://sf.net/projects/pd-gem


More information about the Pd-list mailing list