[PD] testing 0.41-0test6 notes

ilya .d ild0012 at londonmet.ac.uk
Fri Oct 12 10:55:11 CEST 2007

i have been running the 0.41-0test6 for a few weeks now (may be it's
already a month) ..

i usually keep pd running all the time , just with dsp swithced of (well
sometimes i forget to do even that).

when i used version 0.40 i almost havent had any crashes - apart from
when myself screwed something up and it hang cause that was too much ;]

basiclly what i noticed about the 0.41-0 , that after i leave it running
for a while - pd-gui sort of hangs, so it keeps saying 'watchdog:
signaling pd ...'

after i kill the gui - it stops saying that, but there are still two
proceses hanging - pd and pd-watchdog, i couldn't manage to kill those
yet ..
there actually two pairs hanging right now ..
it didn't have any sofisticated patches open - just a couple of pretty
basic abstractions in my init patch and probably a few helpfiles were
left overnight.

i did modify pd.tk , it is work in progress , but i attach it here.

i got gentoo-linux system, which is relatively stable and up-to-date.

gcc (GCC) 3.4.6 (Gentoo 3.4.6-r2, ssp-3.4.6-1.0, pie-8.7.10); glibc-2.5;
linux-2.6.20-gentoo-r8; Tcl/Tk version 8.4 ..
i got CONFIG_RT_MUTEX=y, but icouldn't sort out pam_limits to really
enable it yet.
i run pd with -rt, may that cause actual problem ?
i ran 0.40 with -rt as well, was no porblem.

Companies Act 2006 : http://www.londonmet.ac.uk/companyinfo

-------------- next part --------------
A non-text attachment was scrubbed...
Name: pd.tk
Type: text/x-tcl
Size: 154063 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20071012/93858f6a/attachment.tk>

More information about the Pd-list mailing list