[PD] advise on making mjpeg, pdp and libquicktime happy

danja vasiliev binary.koala at gmail.com
Wed Oct 17 02:35:50 CEST 2007

hello dear all,
pardon me for cross posting this but the issue seems to be somewhat
awkward - for the last several days i was trying to get [pdp_qt] take my
mjpeg video files but was miserably failing:

pdp_qt: video stream found (640x480 pixels, 6 fps, 897 frames, MJPG codec)
pdp_qt: WARNING: unsupported video codec
pdp_qt: ERROR: no usable video stream found.

i would probably have given up at this very point but got totally
abscessed when it worked in *pure:dyne* 2.3.66 ! there i can load my
mjpegs easily, codec is there everything is working (great job btw).
since then i tried to match all relative libs and bins in my ubunty
feisty with p:d, however it wouldn't solve the issue....

i had compiled all the parts from most recent sources,
pdp-0.12.5 compiled against libquicktime-0.9.10:

danja at t43:~/work/PD-parts/libquicktime-0.9.10$ ./configure --enable-gpl
libdv:      Yes
vorbis:     Yes
lame:       Yes
libjpeg:    Yes
libpng:     Yes
libavcodec: Yes
gtk >= 2.4.0: Yes
Alsa        Yes
GPL plugins Enabled
faac        Yes
faad2       Yes
x264        Yes

danja at t43:~/work/PD-parts/pdp-0.12.5-test-7$ ./configure
checking for lqt_decode_video in -lquicktime... yes
checking for glXSwapBuffers in -lGL... yes
checking for SDL_Init in -lSDL... yes
target is linux
used configure options:

also tried the current ubuntu packages of libquicktime and pd-extended
from http://autobuild.puredata.info/auto-build/latest/ with no result.
i have a clue that libquicktime is not making use of it's 'plugins' to
load non-qt files, but i can't trace the problem...
i really hate to convert my mjpegs in to .mov, please help me not to do it.


    _|_       danja vasiliev
 ---(*)---    http://k0a1a.net/recent
   " ' "      +31-64-2654486

More information about the Pd-list mailing list