[PD] Pd-extended final release candidate - please test!

IOhannes m zmoelnig zmoelnig at iem.at
Thu Oct 18 09:34:21 CEST 2007

Hans-Christoph Steiner wrote:
> On Oct 17, 2007, at 2:48 PM, Mathieu Bouchard wrote:
>> On Tue, 16 Oct 2007, IOhannes m zmoelnig wrote:
>>> newer versions of debian (and therefore ubuntu) have replaced
>>> libquicktime0 (0.9.x) by libquicktime1 (1.0.x)
>>> most likely these are binary compatible
>> 0.9.7 and 0.9.8 are definitely not binary-compatible with each other, 
>> although package systems allow upgrade from one to the other.
>> more generally, this is about versions < 0.9.8 vs >= 0.9.8.

my reply was rather generic.
i haven't tried whether it actually works or not, nor did i care.

and true, i should have written "maybe these are binary compatible" 
instead of "most likely [...]"

i tried to avoid answers like "dude, compile it yourself" or "the only 
thing hans needs for getting gutsy packages is a gutsy machine. 
donations are welcome"

> Yeah, libquicktime went thru a spasm of API-breaking (and probably 
> ABI-breaking) changes on the path from 0.9 to 1.0.  Most of the 0.9.x 
> versions are not compatible with each other.

i never noticed this!
i don't think i have changed a line of code in the quicktime4linux code 
of Gem for ages.
to be precise, i haven't changed a line since August 2006, when there 
was 0.9.7 in debian.
but then, i might have just been lucky and used the "right" functions...


More information about the Pd-list mailing list