[PD] GEM error on latest pd extended with Ubuntu Gutsy

altern altern2 at gmail.com
Wed Oct 31 09:08:35 CET 2007


the video does not seem corrupted i can open it with VLC, no problem. I 
tried to find the reason for the error and I found that I can use the 
first frame but as soon as I go the the second or further it doesnt 
display it.

btw. passing mode 0 to pix_texture crashed PD. I was trying this to 
avoid the "gl invalid enumerant" problem i am getting on windows. I 
guess I might have to re construct my patch step by step to find the 
critical area. Bad because I dont have the time before the installation 



Roman Haefeli(e)k dio:
> On Wed, 2007-10-31 at 05:23 +0100, Thomas Mayer wrote:
>> Roman Haefeli wrote:
>>> On Tue, 2007-10-30 at 13:38 +0100, Thomas Mayer wrote:
>>>> Maybe the video is corrupt, have you tried transcoding the video with
>>>> mencoder or transcode?
>>>> Try
>>>> $ mencoder -ovc xvid -xvidencopts bitrate=800 -oac copy -o train.avi
>>>> train.mov
>>>> and load the film train.avi
>>> hi thomas
>>> maybe i missed something, but i don't quite see why you are suggesting
>>> to reencode the movie to avi-container with xvid codec. 
>> I don't have much experience with different codecs/containers and Gem,
>> but - as I said - my first guess is, that the movie is somehow corrupt.
>> So 1. reencoding the movie would be an option to check for this, 2.
>> mencoder is easy to install on a Linux system and 3. this is a setting
>> that works on my system, as mencoder with -ovc lavc produces movies,
>> that Gem (pd-extended 0.39-3 on Debian) can't load. That was merely an
>> idea for troubleshooting.
> lavc is a codec family, not a codec. you need to specify a codec with
> '-ovc lavc -lavcopts vcodec=<codecname>'. 
> however, i didn't want to suggest, that i do _not_ believe, that the
> file could be corrupt, but i would have tried a different codec first,
> that is more likely to work. 
> my suggestion is this:
> mencoder input.mov -ovc lavc -lavcopts vcodec=mjpeg -nosound -of lavf
> -lavfopts format=mov -o output.mov  
> # if you use an older version of mencoder, you probably need to add a
> # flag called 'i_certify_not_to_use_b_frames' (don't know the exact name
> # but you'll find it in the manual.
> (in one line)
> this works at least here and some other people reported, that it works.
> it would be interesting to know, if it also helps in enrike's case 
> roman
> ___________________________________________________________ 
> Der frühe Vogel fängt den Wurm. Hier gelangen Sie zum neuen Yahoo! Mail: http://mail.yahoo.de
> ------------------------------------------------------------------------
> _______________________________________________
> PD-list at iem.at mailing list
> UNSUBSCRIBE and account-management -> http://lists.puredata.info/listinfo/pd-list

More information about the Pd-list mailing list