[GEM-dev] Gem says quicktime ok, then disagrees with itself

IOhannes m zmoelnig zmoelnig at iem.at
Wed Jun 29 09:12:33 CEST 2005

B. Bogart wrote:
> Hey Johannes,
> The text should probably changed to something that makes more sense
> perhaps:
> FFMPEG loader FAILED... Maybe quicktime?
> quicktime4linux loader FAILED... Maybe mpeg?
> MPEG3 loader FAILED... I give up...
> error: GEM: pix_film: Unable to open file: /raid0/media/dv_capture1.mov

and speaking of this: does anybody have an idea how we could change the 
order of tried decoding libraries dynamically ?

the problem is, that some libraries would decode faster than others but 
do not grant frame-wise random access.
probably it would be good to have people choose what decoding library 
they would prefer.
but then, this only makes sense on linux, since that is the only 
platform that needs multiple libraries for decoding.

> Anyone have this working?? I even recompiled Gem with libavcodeccvs from
> the mplayer repository still no dice... It it was not so easy that first
> time.... *sigh*

i think i have already said this before, but i have to admit (again) 
that i haven't been able to open _any_ video with FFMPEG (i/o error).
probably making this work would help....


More information about the GEM-dev mailing list