[GEM-dev] Gem pix_video on Fedora Core 5

thewade pdman at aproximation.org
Sun May 28 19:11:52 CEST 2006

Quoting Georg Holzmann <grhPD at gmx.at>:

> Hallo!
>> Except that pix_video still doesn't work with udev: /dev/dv1394/0
>> I have tried changing to [driver 1< when rendering was enabled and this
>> crashed PD.
>> I tried [driver 1< before rendering and PD didn't crash but I didn't get
>> video.
>> With [device /dev/dv1394/0< I got the following message:
>> device-err: 0
>> DV4L: closed
> hm ... I thought that this works ... (but never tried it) ...
> anyway, you can change the following in videoDV4L.cpp (I think line 194):
>      if ((fd=open("/dev/dv1394", O_RDWR)) < 0)    {
> to:
>      if ((fd=open("/dev/dv1394/0", O_RDWR)) < 0)    {
> and then recompile ...

I tried this with FC4 and again just now with FC5 and I get the 
following message in both cases:
GEM: Graphics Environment for Multimedia
GEM: ver: 0.90
GEM: compiled: May 27 2006
GEM: maintained by IOhannes m zmoelnig
GEM: Authors :	Mark Danks (original version on irix/windows)
GEM: 		Chris Clepper (macOS-X)
GEM: 		Daniel Heckenberg (windows)
GEM: 		James Tittle (macOS-X)
GEM: 		IOhannes m zmoelnig (linux/windows)
GEM: using SSE2 optimization

When I open 00.SimpleVideo I see:
video driver 0: video4linux
video driver 1: ieee1394 for linux

And then when I send pix_video the [driver 1< message I see:
DV4L: closed

Is there a way to run all these operations in a more verbose mode so 
I/we can see what is actually failing?

For example is Gem failing to open the stream, or does Gem open the 
stream and then encounter a format problem? Maybe file permissions are 
what is causing the problem?

What should I try next?

Thanks again for the help!

More information about the GEM-dev mailing list