[GEM-dev] Gem pix_video on Fedora Core 5

cyrille henry cyrille.henry at la-kitchen.fr
Sun May 28 20:08:23 CEST 2006


this look like the same problem as me.
the problem is in pix_videoNEW.cpp

the video transfer (m_videoHandle->startTransfer();) is enable in the 
startRendering fonction and at the object creation (in pix_videoNEW, via 

so when loading a patch, and then creating the gemwindows, the transfert 
is started 2 time. this create some problems.

it should work if you create the gemwindow, and then create the 
pix_video object.

the quick and dirty solution is to comment the lines 78 and 86 of 

you should then have :

void pix_videoNEW :: startRendering(){
   if (!m_videoHandle) {
     post("GEM: pix_video: do video for this OS");
   post("pix_videoNEW: starting transfer");
//  m_videoHandle->startTransfer();

// stopRendering
void pix_videoNEW :: stopRendering(){
  // if (m_videoHandle)m_videoHandle->stopTransfer();

this works for me.
i don't know the solution for a good fix of this problem.


thewade a écrit :
> I installed Fedora Core 5 and now I can build and load gem without 
> disabeling anything! Sweet!
> Except that pix_video still doesn't work with udev: /dev/dv1394/0
> I have tried changing to [driver 1< when rendering was enabled and this 
> crashed PD.
> I tried [driver 1< before rendering and PD didn't crash but I didn't get 
> video.
> With [device /dev/dv1394/0< I got the following message:
> device-err: 0
> DV4L: closed
> Is there a way to get Gem pix-video to work in fedora core 5 with udev 
> or is the only way to get pix_video to work is to use devfs?
> Thanks all!
> -thewade
> _______________________________________________
> GEM-dev mailing list
> GEM-dev at iem.at
> http://lists.puredata.info/listinfo/gem-dev

More information about the GEM-dev mailing list