[GEM-dev] Gem pix_video on Fedora Core 5

thewade pdman at aproximation.org
Mon May 29 03:12:36 CEST 2006


Thank you for the help Cyrille Henry, but unfortunately I still cannot 
see output from my dv1394 device under FC5/udev and Gem.

I tried both creating pix_video after the window is created (still 
using 00.SimpleVideo) and commenting out thoes lines described below 
and recompiling.

Commenting out thoes lines made it so I couldn't crash PD with Gem 
anymore, but I still could see no video.

Creating the pix_video object after sending the gemwin the [create< 
message also did not allw me to see the video.

Are there any other tricks I can try? Does nobody else here use Fedora 
or Redhat? Is there a way to get more verbose or debug error messages 
that may help you to help me, or help me to help myself?

Does IEEE1394 video work any better on Winblows? I have a super slow 
machine from 2000 that I could try to run stuff on - though I am 
hesitant because a 700Mhz machine probably can't do much... Plus 
without a compiler for windows I have to use older binaries, right?

I can run dvgrab while Gem is running and capture video, but Gem can 
still not see anything... poop.

As always, thanks for the help!

Quoting cyrille henry <cyrille.henry at la-kitchen.fr>:

> hello,
> this look like the same problem as me.
> the problem is in pix_videoNEW.cpp
> the video transfer (m_videoHandle->startTransfer();) is enable in the
> startRendering fonction and at the object creation (in pix_videoNEW, via
> drivermess(0))
> so when loading a patch, and then creating the gemwindows, the transfert
> is started 2 time. this create some problems.
> it should work if you create the gemwindow, and then create the
> pix_video object.
> the quick and dirty solution is to comment the lines 78 and 86 of
> pix_videoNEW.cpp
> you should then have :
> void pix_videoNEW :: startRendering(){
>    if (!m_videoHandle) {
>      post("GEM: pix_video: do video for this OS");
>      return;
>    }
>    post("pix_videoNEW: starting transfer");
> //  m_videoHandle->startTransfer();
> }
> /////////////////////////////////////////////////////////
> // stopRendering
> //
> /////////////////////////////////////////////////////////
> void pix_videoNEW :: stopRendering(){
>   // if (m_videoHandle)m_videoHandle->stopTransfer();
> }
> this works for me.
> i don't know the solution for a good fix of this problem.
> cyrille
> thewade a écrit :
>> I installed Fedora Core 5 and now I can build and load gem without 
>> disabeling anything! Sweet!
>> Except that pix_video still doesn't work with udev: /dev/dv1394/0
>> I have tried changing to [driver 1< when rendering was enabled and 
>> this crashed PD.
>> I tried [driver 1< before rendering and PD didn't crash but I didn't 
>> get video.
>> With [device /dev/dv1394/0< I got the following message:
>> device-err: 0
>> DV4L: closed
>> Is there a way to get Gem pix-video to work in fedora core 5 with 
>> udev or is the only way to get pix_video to work is to use devfs?
>> Thanks all!
>> -thewade
>> _______________________________________________
>> GEM-dev mailing list
>> GEM-dev at iem.at
>> http://lists.puredata.info/listinfo/gem-dev

More information about the GEM-dev mailing list