[PD-cvs] [git]Pd-extended branch, patch_series, updated. cbc5ddc521279f9bbb169af140d99347309ceaab

Hans-Christoph Steiner eighthave at users.sourceforge.net
Mon Jun 13 20:28:13 CEST 2011


This is an automated email from the git hooks/post-receive script. It was
generated because a ref change was pushed to the repository containing
the project "Pd-extended".

The branch, patch_series has been updated
  discards  7fb826f54c6967f81aad8b4816243ad1f7453a94 (commit)
       via  cbc5ddc521279f9bbb169af140d99347309ceaab (commit)
       via  888952da46faffeafc28b9d58b9544bf6c96ed29 (commit)
       via  42ce2c5ef5b1d92febc34d6ba70c54f05683ca80 (commit)

This update added new revisions after undoing existing revisions.  That is
to say, the old revision is not a strict subset of the new revision.  This
situation occurs when you --force push a change and generate a repository
containing something like this:

 * -- * -- B -- O -- O -- O (7fb826f54c6967f81aad8b4816243ad1f7453a94)
            \
             N -- N -- N (cbc5ddc521279f9bbb169af140d99347309ceaab)

When this happens we assume that you've already had alert emails for all
of the O revisions, and so we here report only the revisions in the N
branch from the common base, B.

Those revisions listed above that are new to this repository have
not appeared on any other notification email; so we list those
revisions in full, below.

- Log -----------------------------------------------------------------
commit cbc5ddc521279f9bbb169af140d99347309ceaab
Author: IOhannes m zmoelnig <zmoelnig at iem.at>
Date:   Tue May 24 19:05:58 2011 +0200

    cleanup soundfile parsers: reduce number of casts
    
    rather than doing:
      nchannels = swap4(((t_nextstep *)buf)->ns_nchans, swap);
      format = swap4(((t_nextstep *)buf)->ns_format, swap);
      headersize = swap4(((t_nextstep *)buf)->ns_onset, swap);
    we now do:
      t_nextstep*nsbuf=(t_nextstep *)buf;
      nchannels = swap4(nsbuf->ns_nchans, swap);
      format = swap4(nsbuf->ns_format, swap);
      headersize = swap4(nsbuf->ns_onset, swap);
    
    this gives less warnings about type-punning, and makes the code more readable
    (fewer casts to parse by humans :-))

commit 888952da46faffeafc28b9d58b9544bf6c96ed29
Author: IOhannes m zmoelnig <zmoelnig at iem.at>
Date:   Tue May 24 19:05:18 2011 +0200

    replace float/int casts with unions.
    
    using float/int casts won't work with heavy optimization, as it breaks
    type-punning.
    
    see http://gcc.gnu.org/onlinedocs/gcc-4.5.0/gcc/Optimize-Options.html#index-fstrict_002daliasing-787

commit 42ce2c5ef5b1d92febc34d6ba70c54f05683ca80
Author: IOhannes m zmoelnig <zmoelnig at iem.at>
Date:   Tue May 24 19:00:45 2011 +0200

    implement PD_BIGORSMALL() with unions
    
    using float/int casts won't work with heavy optimization, as it breaks
    type-punning.
    see http://gcc.gnu.org/onlinedocs/gcc-4.5.0/gcc/Optimize-Options.html#index-fstrict_002daliasing-787

-----------------------------------------------------------------------

Summary of changes:
 po/fr.po          |  982 ++++++++++++-----------------------------------------
 src/d_math.c      |   51 ++-
 src/d_soundfile.c |   96 +++---
 src/m_pd.h        |   47 +++-
 4 files changed, 349 insertions(+), 827 deletions(-)


hooks/post-receive
-- 
Pd-extended



More information about the Pd-cvs mailing list