[PD-dev] Compiling Gem-0.87 on SUSE8

bbogart at ryerson.ca bbogart at ryerson.ca
Fri Dec 6 20:30:08 CET 2002

Hello all,

I managed to compile gem-0.87 perfectly on my home
machine, but still can't get it to compile at work.
I'm running SUSE8 on both machines. 

At work the first thing I had to do was edit the
makefile so that it could find the libmpeg3.h file,
which is installed in
/usr/include/libmpeg3/libmpeg3.h (the ./configure
script does not find it) 

then I had to install the png developer package
because it seems the normal png package does not
include png_set_compression_level in -lpng

So now I'm really stuck, I've been able to compile
but get the unresolved symbol error upon loading Gem:

Gem: can't load
/usr/lib/libquicktme.so.0: undefined symbol: g_log

I tried searching for g_log in quicktime.h without
any luck, anyone have any ideas on this one? (I sure
can't figure out why it worked at home, with the
same version of SUSE)

I have quicktime4linux and quicktime4linux devel
packages installed. /usr/lib contains these qt libs:

libqt-mt.so.2:         symbolic link to
libqt-mt.so.3:         symbolic link to
libqt.so.2:            symbolic link to
libqt.so.3:            symbolic link to
libquicktime.a:        current ar archive
libquicktime.so:       symbolic link to
libquicktime.so.0:     symbolic link to
libquicktime.so.0.1.3: ELF 32-bit LSB shared object,
Intel 80386, version 1 (SYSV), not stripped
libqutil.so.1:         symbolic link to

More information about the Pd-dev mailing list