[PD-dev] Still yuv problems installing latest Gem CVS on linux...

tigital tigital at mac.com
Thu Jan 9 23:35:44 CET 2003

>On 01.06 15:08 tigital wrote:
>>...yuv_* isn't really supported on any platforms other than OS X, 
>>Yet...but we're working on it!  You may wish to remove that 
>>directory, or change the make file so that it doesn't try to 
>>compile that stuff...
>Latest Gem cvs compiles when I removed the two references to yuv in 
>the Makefile.
>But the lib does not load:
>/usr/local/src/Gem/Gem.pd_linux: /usr/local/src/Gem/Gem.pd_linux: 
>undefined symbol: yuv_emboss_setup
>Gem: can't load library
>In my limited knowledge about such things, I have tried several 
>"make distclean" to make sure that I am running from a clean slate, 
>but I can't find where the reference to yuv_emboss_setup outside of 
>the yuv directory comes from.
>I hand removed Base/GemSetup.o to make sure it was rebuilt but still no go.
>Any ideas ?
hey Marco,

...each directory of objects has it's own setup file, so it seems 
like the yuv setup.h is still being incorporated by 
Base/GemSetup.cpp...so, one way around this would be to edit 
Base/GemSetup.cpp and comment out the following lines:

#include "../yuv/setup.h"



...then ya should be ok!


More information about the Pd-dev mailing list