[PD-dev] devel_0_37 branch

Frank Barknecht fbar at footils.org
Mon Jun 2 19:05:38 CEST 2003

guenter geiger hat gesagt: // guenter geiger wrote:

> Strange, I tested with jack 0.50 and 0.71. on two machines and it worked
> on both (notebook and desktop with SBLive). Furthermore I did not really
> change anything in the code.
> Clueless up to now.

It seems to be a jack problem: I can use pd with jack running on "hw:0" but
not with Jack on device "default". In fact, Jack doesn't produce sound at all
with "default" here, which is strange, but not Pd's fault.

> Is this with some special setting. I have the problem that you described
> with the nasty startup sound too, but then it works.
> Again no idea.
> I could port the modified alsa version from 0_36_devel to 0_37_devel,
> maybe this helps.

I think, I still have Pd 0.36 with the old alsa code here, and when I try
to run with "-alsadev default" audio is stuck. Being able to use the
named interface is probably much more flexible, when it comes to
multichannel cards thanks to asoundrc magic - so I don't necessarily
"want my old Pd back". 

I'm quite sure, that the idiosyncratic ICE1712 chipset is the reason. I
also have a SBLive in this machine, but cannot test right now because
I have no cable for it. :(

But the ICE1712 is a bit strange in that ALSA  accesses the hw-layer
with a certain setting (period size, samplerate, bitdepth), for
conversions the plug-layer seems to be needed. 

I guess now most of my problems are solved and I can update Pd on my
main machine. Will you put a debian directory into the pd-dir? 

One problem remains: If I start a quite complex patch with Pd in
"-realtime" mode and Jack, Pd just hangs. The error message of Jack

  subgraph starting at pure_data_0 timed out (subgraph_wait_fd=11,
   status = 134629112, state = Running)
  client pure_data_0 error: awake_at = 37365543201 state = 2 timed_out
   = 0

I tried playing with the jack -t option and set it very high and very
low, but it didn't help. I guess, I might disable jack_connecting on
startup again, but maybe this could be a command line option later?

(But this also happens if I start Pd, manually jack_disconnect Pd and
try to open that patch. I could send you the patch, but it still has
some highly personalized absolute paths in it.)

 Frank Barknecht                               _ ______footils.org__

More information about the Pd-dev mailing list