[PD-dev] problem making Pd.app with TclTk-8.4.9

B. Bogart ben at ekran.org
Fri Apr 8 22:53:28 CEST 2005

yeah the same thing happend to me with the pixelTANGO.app, I fixed it by
  recompiling PD with the 8,4,9 headers/frameworks.

I think the sticky bit is that I have headers MANUALLY copied into
/usr/local/lib for PD's configure to find them. (otherwise it will
always fail trying to find the tk stuff). I think the reason why I got
it to work was that I was recompiling PD with the old 8.4.1 headers
initially, and then changed them for the new ones and then it worked. I
think this is the case anyhow...

You can always download my pixelTANGO.app and use that as the basis for
the new installer/future releases of PD with 8.4.9 included.


It works on all machines, and I've hacked the tk file to turn on
antialiasing on all lines.

In case my memory of how I *really* got it to work differs from the
above maybe you can figure out what I did by looking at the result.

No reason why you guys should not be able to get it to work also.


Hans-Christoph Steiner wrote:
> So I have built a Pd.app using TclTk 8.4.9, which includes all of
> Jamie's super handy graphics fixes. It works fine if I use pd from the
> command line, i.e. the old way. But whenever I run the Pd.app, I get this:
> --------------------------
> hans at sla:mac-stuff > Pd-0.38-4_TclTk-8.4.9.app/Contents/MacOS/Pd
> alloc: invalid block: 0xa08fc9c: a 80 0
> Abort
> --------------------------
> It seems to be the Tcl version of a kernel panic. Any ideas as to how to
> troubleshoot this? Or even better, what this error message means in
> particular? This seems to affect TclTk 8.4.5 thru 8.4.9. 8.4.4 works fine.
> I really want to get the newer TclTk working because it is sooo much
> nicer: faster, many bug fixes, looks better.
> .hc
> ____________________________________________________________________________
> ¡El pueblo unido jamás será vencido!
> ------------------------------------------------------------------------
> _______________________________________________
> PD-dev mailing list
> PD-dev at iem.at
> http://lists.puredata.info/listinfo/pd-dev
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 256 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-dev/attachments/20050408/eb232b4a/attachment.pgp>

More information about the Pd-dev mailing list