[PD-dev] problem making Pd.app with TclTk-8.4.9

Hans-Christoph Steiner hans at eds.org
Mon Apr 18 06:05:40 CEST 2005

I am having no luck getting it running properly with 8.4.9.  Your  
PixelTANGO.app works for me.  Anything I can do to jog your memory as  
to how you got it working?

I have a hunch: starting with MacOS X 10.3, the Tcl.framework 8.4.4 is  
included, but not the Tk.framework.  I noticed that  
usr/lib/libtcl8.4.dylib is a link to   
/System/Library/Frameworks/Tcl.framework/Versions/8.4/Tcl (8.4.4)  So  
maybe you created all of the links in /usr/local/lib to 8.4.9 and that  

I am going to try some rendition of that idea...


On Apr 8, 2005, at 4:53 PM, B. Bogart wrote:

> yeah the same thing happend to me with the pixelTANGO.app, I fixed it  
> by
>  recompiling PD with the 8,4,9 headers/frameworks.
> I think the sticky bit is that I have headers MANUALLY copied into
> /usr/local/lib for PD's configure to find them. (otherwise it will
> always fail trying to find the tk stuff). I think the reason why I got
> it to work was that I was recompiling PD with the old 8.4.1 headers
> initially, and then changed them for the new ones and then it worked. I
> think this is the case anyhow...
> You can always download my pixelTANGO.app and use that as the basis for
> the new installer/future releases of PD with 8.4.9 included.
> www.ekran.org/ben/research/PixelTANGO-v0.3.3G4.tgz
> It works on all machines, and I've hacked the tk file to turn on
> antialiasing on all lines.
> In case my memory of how I *really* got it to work differs from the
> above maybe you can figure out what I did by looking at the result.
> No reason why you guys should not be able to get it to work also.
> b>
> Hans-Christoph Steiner wrote:
>> So I have built a Pd.app using TclTk 8.4.9, which includes all of
>> Jamie's super handy graphics fixes. It works fine if I use pd from the
>> command line, i.e. the old way. But whenever I run the Pd.app, I get  
>> this:
>> --------------------------
>> hans at sla:mac-stuff > Pd-0.38-4_TclTk-8.4.9.app/Contents/MacOS/Pd
>> alloc: invalid block: 0xa08fc9c: a 80 0
>> Abort
>> --------------------------
>> It seems to be the Tcl version of a kernel panic. Any ideas as to how  
>> to
>> troubleshoot this? Or even better, what this error message means in
>> particular? This seems to affect TclTk 8.4.5 thru 8.4.9. 8.4.4 works  
>> fine.
>> I really want to get the newer TclTk working because it is sooo much
>> nicer: faster, many bug fixes, looks better.
>> .hc
>> ______________________________________________________________________ 
>> ______
>> ¡El pueblo unido jamás será vencido!
>> ---------------------------------------------------------------------- 
>> --
>> _______________________________________________
>> PD-dev mailing list
>> PD-dev at iem.at
>> http://lists.puredata.info/listinfo/pd-dev


                     There is no way to peace, peace is the way.
										-A.J. Muste
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2353 bytes
Desc: not available
URL: <http://lists.puredata.info/pipermail/pd-dev/attachments/20050418/14a622ca/attachment.bin>

More information about the Pd-dev mailing list