[PD-dev] Re: Restructuring of CVS/externals

Mathieu Bouchard matju at artengine.ca
Fri Feb 3 06:31:58 CET 2006

On Thu, 2 Feb 2006, Hans-Christoph Steiner wrote:

> I could be convinced to use "_to_", but "to" aka [mtof] is not clear.  
> Another idea is "->".  [hertz->midi], [hsv->rgb].  Actually, I think I
> might like "->" even better.

Precedent for "->" includes Scheme:

(symbol->string 'bang) gives "bang"
(string->symbol "bang") gives bang

> While I am at it, I think that we should try to come up with meaningful
> names. We have plenty of memory these days, even on 10 year old
> computers, we don't need to use short names.

What we don't have plenty of, is screen space, especially when Pd eats it 
horizontally and doesn't let people resize objectboxes to their width of 

> And its also now pretty clearly established in computer science that
> clear naming saves much more time than short names.  Its all about
> avoiding bugs.

clear names are clearer.
short names are shorter.
however, long names aren't necessarily clearer...

what i said about "_to_" wasn't too serious, but i don't know of a good
alternative. GF has [#rgb_to_yuv] and [#rgb_to_greyscale], but also has 
[#import] which turns anything to a grid, and [#export], which converts a 
grid to a seq of floats, and [#export_list], which converts a grid to a 
list, and [#export_symbol], which converts a grid to a symbol, so i'm not 
all consistent about it.

 _ _ __ ___ _____ ________ _____________ _____________________ ...
| Mathieu Bouchard - tél:+1.514.383.3801 - http://artengine.ca/matju
| Freelance Digital Arts Engineer, Montréal QC Canada

More information about the Pd-dev mailing list