[PD-dev] GameCube gamepad

Michal Seta mis at artengine.ca
Wed Aug 30 04:01:26 CEST 2006

Hi all, Hans especially,

I tried to use the GameCube joystick with pd recently.  GameCube pad
needs a USB adapter and I'd swear it used to work with some joystick
extern in pd a couple of years ago.

First I tried
with the (deprecated?) [linuxjoystick] and today with [hid].  

[linuxjoystick] reports this:

[linuxjoystick] $Revision: 1.6 $, written by Hans-Christoph Steiner <hans at eds.org>
Configuring Austgame GameCube to USB convertor on /dev/input/event2

Supported events:
 Reset (type 0) 
    Event code 0 (Reset)
    Event code 1 (Key)
    Event code 3 (Absolute)
 Key (type 1) 
    Event code 256 (Btn0)
    Event code 257 (Btn1)
    Event code 258 (Btn2)
    Event code 259 (Btn3)
    Event code 260 (Btn4)
    Event code 261 (Btn5)
    Event code 262 (Btn6)
    Event code 263 (Btn7)
 Absolute (type 3) 
    Event code 0 (X)
    Event code 1 (Y)
    Event code 2 (Z)
    Event code 5 (Rz)
    Event code 6 (Throttle)
    Event code 16 (Hat0X)
    Event code 17 (Hat0Y)

Using 0 relative axes, 7 absolute axes, and 8 buttons.

dmesg reports this:

usb 3-2: USB disconnect, address 3
usb 3-2: new low speed USB device using uhci_hcd and address 4
input: Austgame GameCube to USB convertor as /class/input/input4
input,hiddev96: USB HID v1.00 Joystick [Austgame GameCube to USB convertor] on usb-0000:00:10.2-2

[hid] reports 

[hid] opened device 2 (/dev/input/event2): Austgame GameCube to USB convertor
pre hid_build_element_list
info: open 1
info: device 2
[hid] Building device list...
Found 'AT Translated Set 2 keyboard' on '/dev/input/event0'
Found 'Logitech USB-PS/2 Optical Mouse' on '/dev/input/event1'
Found 'Austgame GameCube to USB convertor' on '/dev/input/event2'
[hid] completed device list.

but it does not recognize any events.


GameCube to USB convertor
Manufacturer: Austgame
Speed: 1.5Mb/s (low)
USB Version:  1.00
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 8
Number of Configurations: 1
Vendor Id: 05e3
Product Id: 0681
Revision Number:  1.00

Config Number: 1
	Number of Interfaces: 1
	Attributes: 80
	MaxPower Needed: 150mA

	Interface Number: 0
		Name: usbhid
		Alternate Number: 0
		Class: 03(HID  ) 
		Sub Class: 0
		Protocol: 0
		Number of Endpoints: 1

			Endpoint Address: 81
			Direction: in
			Attribute: 3
			Type: Int.
			Max Packet Size: 8
			Interval: 10ms

This thing is recognized by jscalibrator and I can use it with
different apps (even xmms).  Any idea what could be a problem here and
if there is any hope?


More information about the Pd-dev mailing list