[PD-dev] proposed C change: consistent naming

Hans-Christoph Steiner hans at eds.org
Tue Jan 13 22:11:46 CET 2009

I think it would make a lot of sense to rename a few functions/procs  
so that they all match the pd message, but I haven't does this yet in  
pd-devel. For example:

"mouse" message:
  Tcl: pdtk_canvas_click  -> pdtk_canvas_mouse
  C: canvas_mousedown -> canvas_mouse

"mouseup" message
  Tcl: pdtk_canvas_mouseup
  C: canvas_mouseup

This makes the code much easier to follow, and therefore debug and  
improve :)



If nature has made any one thing less susceptible than all others of  
exclusive property, it is the action of the thinking power called an  
idea, which an individual may exclusively possess as long as he keeps  
it to himself; but the moment it is divulged, it forces itself into  
the possession of everyone, and the receiver cannot dispossess himself  
of it.            - Thomas Jefferson

More information about the Pd-dev mailing list