[PD-dev] pow~ in Cyclone [was: Re: stripping down Pd-extended's default libs]
padawan12 at obiwannabe.co.uk
Wed Feb 18 16:02:52 CET 2009
On Wed, 18 Feb 2009 15:21:28 +0100
IOhannes m zmoelnig <zmoelnig at iem.at> wrote:
> but which [pow~] _is_ the right one, and which one is backward?
The vanilla one is correct. It is consistent with mathematical
and common syntactical properties of other asymmetrical
(non commutative) operators
subtract A - B the second operand is the amount subtracted from the first
operand (minuend) and the inlet order reflects this.
divide A/B the second operand (divisor) is the second inlet position,
the first operand (dividend) is the first inlet.
So, for exponentiation A^B the first operand (base) is the first
inlet, and the second operand (exponent) is the second inlet.
It's also that the signal domain [pow~] is consistent with
the existing and long established message domain [pow]
At the risk of causing offence, Cyclone [pow~] made a mistake
ordering inlets and I don't think it's good to take the broken
Microsoft approach of putting historical, backwards compatability
above correctness and future simplicity of code.
(FWIW I personally had to change dozens of my own patches
including those already documented in a textbook - the pain
is worth the gain to do things right.)
Use the source
More information about the Pd-dev