[PD-dev] pow~ in Cyclone [was: Re: stripping down Pd-extended's default libs]
martin.peach at sympatico.ca
Thu Feb 19 15:15:02 CET 2009
Frank Barknecht wrote:
> Martin Peach hat gesagt: // Martin Peach wrote:
>> Well isn't it just easier to use something with a different name? If you
>> have a backwards [pow] why not just call it [backwardspow] instead of
>> letting users guess which [pow] is the right one?
> If a former external becomes a builtin in some future Pd version, you
> cannot use something with a different name, you can only rename the
> old external to something else. And what if the new builtin name was
> used by different, conflicting classes? What if Pd gets a [counter]
> builtin as is sometimes requested?
I suggest that the first object to use the name 'owns' the name and any
subsequently invented objects use different names. That's all. If
there's already a [counter] then Pd's new builtin counter would have to
be called [pdcounter] or something. The name doesn't affect the
function, and usually is not much use beyond being a unique identifier.
You still need to look at the help patch to know what any version of
[counter] actually does.
More information about the Pd-dev