[PD-dev] moocow: svn and compilation issues

Bryan Jurish moocow at ling.uni-potsdam.de
Wed Apr 8 21:28:47 CEST 2009

moin Roman,

On 2009-04-06 20:55:10, Roman Haefeli <reduzierer at yahoo.de> appears to
have written:
> hi all, hi bryan
> i tried to compile pdstring from moocow from a fresh svn checkout and
> encountered some issues. 
> - moocow/autoreconf.sh
>  when invoked from shell, it gives the error:
> ../autoreconf.sh: 3: Syntax error: "(" unexpected
> i guess, that is because it is using the wrong shebang. it runs fine,
> when the shebang calls bash and not sh, like:
> #!/bin/bash

You're probably right and autoreconf should call bash rather than sh.

That said, you shouldn't need to call autoreconf.sh (or any
package-local autogen.sh, which serves the same purpose) yourself at all
these days.  Those scripts are meant to be maintainer-only.

> - moocow/pdstring/
> don't know exactly, if that is intended or not, but there seems to be a
> confusion with autogenerated files and files checked out from svn.


> my
> instinct tells me, that files, that are generated by some other scripts
> shouldn't be checked into the repository: when i call './autogen.sh', it
> will create some files.

My instinct (and aesthetics) tell me the same thing.  Nonetheless,
checking the generated files (Makefile.in, config.h.in, configure ...)
into svn is the only way I've found (to date) to get my externals
auto-building nicely with the pd-extended build system.  Without going
into all the gory details, the build farm machines are running so many
different versions of automake and autoconf that it made more sense for
me just to bite the bullet and check in the generated files.  It ain't
pretty, but that's how it is.

> now, when i later run an 'svn update', in the meanwhile those files
> might have changed in the repository, and svn doesn't want to overwrite
> the ones, that were generated by the script.

Yup.  Which is why you probably shouldn't be running autoreconf.sh
yourself, unless you really *are* mucking about with configure.ac,
Makefile.am and the like.  I suppose I probably ought to update the
README to reflect this ;-)

> i am not able to exactly describe what happened, but i just poked around
> a bit and then it worked. i cannot exactly recall all the commands i
> tried. anyway, i had to manually 'rm makefile* config*' followed by 'svn
> update' in order to be able to compile pdstring without errors.

I suspect you eventually ran ./svn-prepare.sh, which is the current Ugly
 Hack which needs to run before things will build; all it really does is
(ln -s ../common .); gory details on why it's required are lurking in
the pd-dev archives.


Bryan Jurish                           "There is *always* one more bug."
jurish at ling.uni-potsdam.de      -Lubarsky's Law of Cybernetic Entomology

More information about the Pd-dev mailing list