[PD-dev] mac save as crash, was: savestate

Kevin Haywood khaywood at ucsd.edu
Thu Sep 13 01:57:37 CEST 2018

I’m getting the Save As crash with test2 on 10.13.6 (still the latest mac).

It’s happened twice, but I can’t replicate it yet. Just now, I copied a small part of an existing patch into a new patch. File > Save, and it crashed, although it did actually save the new patch, and it seems to open fine. Tried recreating the exact same sequence of events again and it doesn’t crash. Tried using Save As… a bunch of times, and it doesn’t crash. But it will, it seems.


> On Sep 11, 2018, at 4:26 PM, Dan Wilcox <danomatika at gmail.com> wrote:
> I'm seeing the same on macOS 10.13.6. This is a crash in the GUI and seems to be something to do with the Tk version as running PD with the built-in version of Tk on my system works fine.
>> On Sep 12, 2018, at 12:20 AM, pd-dev-request at lists.iem.at <mailto:pd-dev-request at lists.iem.at> wrote:
>> From: jakob skouborg <syntaxerror60 at hotmail.com <mailto:syntaxerror60 at hotmail.com>>
>> but I think I might have experienced a bug here on OSX 10.10.5(Yosemite):
>> - When I do a “save as” and I type in the name in the save dialog and then push “ Save as” button, PD crashed. I have not been able to save a patch yet.
>> Can anyone replicate?
>> Thanks and have a great evening ;)
>> Jakob(Jaffasplaffa)
> --------
> Dan Wilcox
> @danomatika <http://twitter.com/danomatika>
> danomatika.com <http://danomatika.com/>
> robotcowboy.com <http://robotcowboy.com/>
> _______________________________________________
> Pd-dev mailing list
> Pd-dev at lists.iem.at
> https://lists.puredata.info/listinfo/pd-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.puredata.info/pipermail/pd-dev/attachments/20180912/db31addf/attachment.html>

More information about the Pd-dev mailing list