Hi List,<br><br>I&#39;m currently running into issues with getting PD Extended 0.41.4 to run on Leopard 10.5. If I let the software run for an extended period of time (say, 30 minutes to a couple of hours) PD/Gem crashes without an error report.  I&#39;m running 1920 x 1080 video playback when this happens and I&#39;ve tested the programming with both two and three layers of video running.<br>

<br>This is happening on a quad core Intel-Xeon Mac with 4 GB of memory (although the same issue is happening if I cannibalize an additional 4 GB), an ATI Radeon card and Blackmagic Intensity for capture.  While I can&#39;t get an error report from PD/Gem, Console is giving me the following:<br>

<br>8/25/09 1:38:48 PM    [0x0-0x18018].org.puredata.pd.wish[271]   
pd(272,0xa03ce720) malloc: *** mmap(size=4149248) failed (error
code=12)    <br>8/25/09 1:38:48 PM    [0x0-0x18018].org.puredata.pd.wish[271]    *** error: can&#39;t allocate region    <br>8/25/09 1:38:48 PM    [0x0-0x18018].org.puredata.pd.wish[271]    *** set a breakpoint in malloc_error_break to debug    <br>

8/25/09 1:38:48 PM    [0x0-0x18018].org.puredata.pd.wish[271]    terminate called after throwing an instance of &#39;std::bad_alloc&#39;<br><br>This is definitely not an area that I&#39;m overly familiar/confident about and would really love to have at least some sort of idea of what could be causing this to happen.  This error is the only error I get with my programming and it&#39;s frustrating since I can&#39;t downgrade to Leopard or run it on another operating system.  Any insight into this issue would be greatly appreciated.  I&#39;ve altered my programming dramatically and stripped it down to the bare bones and still, I have this error occuring.<br>

<br>So, I suppose my question is this... is this a PD/Gem issue with Leopard?  Or something on my side that I&#39;m just not seeing... Any insight into this would be hugely appreciated....<br><br>Thank you,<br>J<br><br><br>

<br>