getting pd to work in NT? or linux?

Charlie Kilpatrick ckilpatrick at
Tue Mar 3 08:13:36 CET 1998

Hi all,

I seem to be having problems getting pd to run on NT.  The error message I
get in a little dialog box is:

The instruction at "0x100162bf" referenced memory at "0x00000010". The
memory could not be "read".

And the output in the command prompt window is:

Pd version 0.21
compiled Thu Jan 15 08:52:27 PST 1998
port 5400
Waiting for connection request...
... connected
pd: ADCs on; DACs on
waveInOpen: A device ID has been used that is out of range for your system.
waveOutOpen: A device ID has been used that is out of range for your system.
midiOutOpen: There is no driver installed on your system.
There are no MIDI input devices.
pd: running.

I've tried this on a couple different puters running NT, but to avail.  It
does work if I run it with the '-nosound' or '-adc' options, but then I
hear no sound. :)

To tell you the truth I'm a little baffled by this because I've written a
program that calls both waveInOpen and waveOutOpen and it works perfectly.
Also, from first glance my source is basically the same as that in pd, with
the one exception that I use the more recent structure WAVEFORMATEX rather
than PCMWAVEFORMAT.  Alas, I've modified pd's code to use that new
structure but the same errors occur. (In fact, I'm not sure this should
have any effect because actually I think the data alignment is the same
between the two structures (except for an extra word at the end of
WAVEFORMATEX), just the field names are different).  I'll take a closer
look at what is different between the two programs later, but I'm wondering
if anyone else has had problems?

Also, I've tried to run pd in linux.  I cannot seem to compile it, however.
 The error message I get is:

make: *** No rule to make target `/usr/include/gnu/stubs.h', needed by
`g_canvas.o'.  Stop.

This file does not exist in my /usr/include/gnu directory.  Does someone
have this file?  Could you send it to me?  The only file that is in that
directory currently is types.h on my system.  It is Debian distribution and
my kernel 2.0.33.

Thanks much for your help,


More information about the Pd-list mailing list