getting pd to work in NT? or linux?

Charles Baker baker at
Tue Mar 3 08:36:14 CET 1998

Very much enjoying the program, Miller....working on simple MIDI controled ring
think "Mantra"!

Well,  I might as well report my errors:
i have
NT 4.0 - TurtleBeach Fiji sound card
Linux (2.0.32- RedHat 5.0) - TurtleBeach Malibu sound card

under NT-
all of pd that I have tested worked well, *except* , apx. 80% of the time, the
DACs are lost
after a few seconds with "dacs died, switching to alternative timing source"
This is too bad, because full-duplex has only worked under NT for me....
once the dacs are happy, things work great. (:-(

under Linux -
well, no full duplex: the app complains that it can't stat /dev/dsp1 (hey, it's
there, looks correct!),
 the card  (actually, /dev/sndstat) reports that it *should * use /dev/dsp1 for
record in full-duplex, which it says it supports.
and, more important , since ver. 0.21, i get an immediate core dump. sigh.
compilation seemed simple enough. ( no errors.) I have no problem with 0.20,
other than no fullduplex, and no fft object..
I did go load tcl7.6/tk4.2, since I've moved on to tcl/tk 8.0 ... 0.20 works
well, as I said.
i will try to gdb the core dump this weekend, but since I no longer enjoy the
priorities of an
academic position (*sigh*- come'on FloridaState and/or Stanford!!), I must
deliver some other
debugging to my employer before I can get to pd....
any ideas?

baker at
baker at
cbaker at

More information about the Pd-list mailing list