Abstraction woes

Mark Danks mdanks at smtp.xaostools.com
Wed Mar 18 18:13:28 CET 1998

Larry Troxler wrote:
> up as "0" instead of "1". The behavior of the abstraction is also
> consistent with this error. bAny ideas? Is this a known bug? (I'm at the

 When I last tried this, (about at .20) it was a problem for me to.  I
found that the arguments only worked in message boxes (not in objects). 
So, I would put the argument into a message box and use the equivalent
of a loadbang to set the object.  I mentioned it to Miller when I was
doing pushit, but there were so many other problems that it probably got
lost in the confusion.

> Second, all I am trying to do is to implement a looping mechanism - an
> object that counts from x to y, transmitting the integers from x to y
> consecutively on its outlet.!!
> I have a feeling there has to be an easier way!

  I can think of a couple of ways.  One, you can use the traditional
"counter" trick with a '+ 1' object looped back onto itself with an
int.  Or, you can use the counter object in MarkEx.  With the trick
above, it should work fine.

Later, Mark

-           Mark Danks             -
-       mdanks at xaostools.com       -
-  http://cybermed.ucsd.edu/mdanks -

More information about the Pd-list mailing list