Compiling pd with SGI -n32 7.3 compilers

Michael A. Thompson mat0001 at
Tue Aug 31 02:04:35 CEST 1999


I just got my hands on an R5000 Indy with the 7.3 compilers on it here
at UNT. I have been trying for 3 days to get pd compiled n32 with these
compilers. I can compile fine with egcs compilers n32... but my problem
is this. I dont get any serious error on the compilation but when I run
the pd-n32 binary I get this tcltk error: Application initialization
failed: invalid command name "tcl_findLibrary". here is what I have
1. compiling only the pd part of the program. pd-gui is still -o32.
doesnt work. pd-gui will not display the patches nor recognize the patch
connections. some thing to do with the -o32 -n32 drawing to the tcltk
canvas I think... I dont know...
2. replaced the libtk and libtcl with -n32 versions and compiled the
whole package -n32. It worked 1 time then nothing else.
Here are my compiler and linker flags.... I want an optimized version
for the O2.
a. -n32 -DN32 -woff 1080,1064,1185 -IPA -Ofast=ip32_5k
-OPT:cray_ivdep=true -r5000 -OPT:roundoff=3 -OPT:IEEE_arithmetic=3.  Im
using -Ofast=ip32_5k  because I plan on running this on an O2... but if
I change it to -Ofast=ip22_5k  (for the indy) same thing happens.
b. I tried this as well: -n32 -DN32 -woff 1080,1064,1185 -IPA -O2
c. -n32 -O2
d. -n32 -O3

same message.
tcl_findLibrary is called from the libtk8.0.a library...

So, Any Ideas?


Michael A. Thompson
[IRIX - NeXTStep - Linux - MacOS - Windows]

Home: (940)382-2086
E-Mail: mat0001 at

More information about the Pd-list mailing list