[PD] pd w/alsa & delta44

Bill Sack wsack at acsu.buffalo.edu
Wed May 9 04:13:46 CEST 2001

hello list,
         i now have a midiman delta 44 for sound in/out. summer project
to get it working w/ linux audio. built and installed the alsa drivers.
i start pd with the following command:

[bsack at t0ast pd]$ pd -alsa -nomidi -inchannels 4 -outchannels 4
-verbose      Pd version 0.32 patch 4
, compiled 11:17:47 May  4 2001
PD-ALSA: using card M Audio Delta 44 at 0xdce0, irq 10
input channels supported: 12-12
... etc.

the "DIO errors" button is red and stays that way. the audio output is
present, but choppy. the audiostatus reports:

audio I/O error history:
seconds ago     error type
     0.00       DAC blocked
     0.02       DAC blocked
     0.04       DAC blocked
... etc.

a question for those who have had success with this card: what other
command-line switches are needed to make pd, alsa, and the card happy? i
have tried various combinations of -frags, -audiobuf, and different
sampling rates with no discernable improvement.

alsa drivers are version 0.5.10b, pd is 0.32p5. hardware is pII 350mHz.
kernel is 2.2.14-5.0 (RedHat 6.2)

i had a similar problem with my notebook when i tried alsa in "native
mode" - it works fine in oss-emulation mode, so i use that. oss-emu mode
doesn't seem to be an option for this 4-channel card, though.

thank you for any suggestions,


Bill Sack
wsack at acsu.buffalo.edu

More information about the Pd-list mailing list