[PD] PD 0.33 test 6 works with alsa 0.9B3 but not 0.9B4

Winfried Ritsch ritsch at iem.kug.ac.at
Mon Jun 11 10:09:55 CEST 2001


 > I've just been entertaining myself with trying to get Pd to run with Alsa
 > 0.9Beta 4.  I had to upgrade to RedHat 7.1 because 0.9Beta4 seems not to work
 > with 2.2 kernels.  And now I find that Pd 0.33test6 (the latest) doesn't work
 > at all with Alsa except in OSS emulation.  OSS emulation seems to work OK
 > at least.
 > If any of you have tried test versions of Pd 0.33 with Alsa 0.9B4 and founf
 > out how to get it to work I'd sure like to know how you do it.  In the
 > meantime I'll continue trying to find out what my problems are.

If got PD to work with ALSA 0.9Beta4 and 2.4.5 (but not 2.4.4 some
socket open troubles)  and the snd-card-rme96 (RME96/8 PST) Soundcard
and MIDI with PCI128 (snd-card-ens1370) and snd-seq-oss. But I failed
with rme9652, since all the anounced features (which are actually
drawbacks in performance) like dev "plug:x,x", "share:x,x" or
"multi:x,x" I cant get to work, even hacking on pd code (doing my own
testing programm). 

I got it to work with the onboard CMIPCI-Card, but using MIDI of this
Card frezzes the computer, so I think some of the drivers have MIDI
broken and I worked a little better (only MIDI-out) if I turn the
APIC (and IO-APIC)-feature in kernel Config on (not SMP).

Also the philosophy in ALSA is that using "mmap -interface" feature
turns out that you have to use a mmap-pointer update routine which in
facts makes a copy of sounddata to the real mmap-memory, which in fact
undermines the idea of mmap and doing the data-conversion (flot to
int32) ourselves. So there I see no point to use mmap in ALSA, since it
does the same: coping sound-data to the device ;-(. So I think best is
using Guenthers driver for Hammerfall (which also provides an stereo
device for eg. snd Soundeditor and so on).

mfg winfried

More information about the Pd-list mailing list