[PD] OS X, Pd, & Tcl/Tk question...

tigital tigital at mac.com
Wed Feb 27 16:29:28 CET 2002


...I know, I know:  the OS X version of Pd is so experimental it may 
not do ANYTHING, but, I wanted to try and see it run, see maybe if I 
can start porting some video stuff...

...so, I ran into a coupla problems which made me curious:

1:  after pulling the folder outta the archive, I just tried to run 
"bin/pd" at the terminal, and got the following:
	MIDI: not yet implemented
	PortAudio on OSX - Latency = 512 frames, 11 msec
	Output Stream Hardware Latency = 0 frames.
	zsh: no such file or directory: 
/Applications/WishShell.app/Contents/MacOS/Wish Shell

What is WishShell?

2:  I then tried to compile on my own, but couldn't...after checking 
the makefile, I noticed that it is expecting a Tk.framework and a 
Tcl.framework in the /Library/Frameworks folder...the thing is, I 
have Tcl/Tk installed and working just fine, but do not have these 
frameworks:  So maybe there are two not-so-compatible releases of 
Tcl/Tk?  I got mine through fink, which places libtcl.dylib in 

looking forward to joining the fun!


More information about the Pd-list mailing list