[PD] Alsa 0.9.0beta12 w/Pd-0.35-test11

Miller Puckette mpuckett at man104-1.ucsd.edu
Tue Mar 12 05:53:47 CET 2002

Hi all,

I conclude from this that I really should change the include file now
(this will make it not work with earlier ALSA versions but it seems that
the old way fails with new ALSA because the makefile insists on
failing whenever there's a warning on compilation.


On Mon, Mar 04, 2002 at 12:22:33PM -0500, Darwin Marcus Johnson wrote:
> Hi,
> when I try to compile pd test 11 alsa support with the latest Alsa 0.9.0beta 
> 12. I run a:
> ./configure --enable-alsa
> make
> make exits with this error:
> cc -DPD -DUNIX  -Wall -W -Wstrict-prototypes  -Werror -Wno-unused 
> -Wno-parentheses -Wno-switch -O6 -funroll-loops -fomit-frame-pointer  
> -DDL_OPEN -DALSA01 -DINSTALL_PREFIX=\"/usr/local\" -I. -c -o ../obj/s_linux.o 
> s_linux.c
> In file included from s_linux.c:45:
> /usr/include/sys/asoundlib.h:1: warning: #warning This header is deprecated, 
> use <alsa/asoundlib.h> instead.
> make: *** [s_linux.o] Error 1
> when I went back and ran make depend it exited with the same error as above.
> any clues ?
> Thanks
> -Darwin

More information about the Pd-list mailing list