[PD] jack trouble

Michal Seta mis at creazone.com
Tue Oct 22 17:01:47 CEST 2002

I'm on a Screamer so...

On Tue, 22 Oct 2002 10:11:08 +0100 (BST)
david casal <D.Casal at uea.ac.uk> wrote:

> Hi all,
> Trying to to PD-->Jack. Ran into trouble:
> I'm running Debian 2.4.18 on a powerbook (pismo G3). Got the CVS pd
> version of devel_0_35 and compiled with './configure --enable-jack
> --enable-alsa'.
> Checked out Jack (CVS), tinkered with configure.in until
> autogen worked.

Have you tried jack_simple_client or somesuch to see if it would connect to the jack server?

> tried to start jack with 'jackd -d alsa -d screamer', and it seemed fine:

you will probably want to start with 'jackd -d alsa -r 44100' bacause I don't think that Apple hardware supports 48000 sr.  Also, try the default alsa device (the above command will choose automatically alsa's plugin layer, which jackd will complain about but it should work anyways).

> loading driver ..
> creating alsa driver ... screamer|1024|2|48000|swmon
> starting engine
> I've got a .asoundrc with:
> pcm.screamer {
> type hw
> card 0
> }

how about adding:

ctl.screamer {
	type hw
	card 0

.. but I'm no wizard...

> pd -jack -verbose
> PD's output:
> Pd version 0.35
> (MIDI stuff)
> using jack interface
> cannot read event connect result from server (No such device)
> cannot connect to server for event stream (No such device)
> (last 2 lines repeated 5 times)
> jack server not running?
> Jack's output:
> **** alsa_pcm: xrun of at least 4.253 msecs
> unknown client ID in ACK connection request
> cannot complete client ACK connection process
> (last 2 lines repeated 5 times)

I have to run jackd and the jackified app under the same uid.

> Thing is, I had quite a bit of trouble compiling ALSA for this powerbook,
> and I fear maybe the thing's gone mad...but I'm able to 'modprobe modprobe
> snd-powermac Any clues, anybody?

Did you try any other alsa audio application?  ecasound? pd with alsa? to make sure that your alsa drivers are working correctly? Also, make sure that it's working full duplex on your machine (easy to check with these 2 apps).

Don't test with xmms because it's known to be deceitful with alsa on a PPC.

BTW, which version of ALSA?  I had some problems with 0.9rc3 and I had to grab the CVS, but I think my problems were mostly MIDI related...


More information about the Pd-list mailing list