[PD] Gem failed after compiled against gcc 3.2 on GentooLinux

patrick pagano ppagano at bellsouth.net
Sun Jan 19 15:35:15 CET 2003

i am no longer on a laptop for linux (my vaio pooped), so i cannot 
comment on radeons
but i am on 7.3 with 320MB ram 1.7GHz

glxgears -info is giving me

[root at localhost root]# glxgears -info
GL_RENDERER   = Mesa DRI Rage128 20010405 Pro AGP 1x x86/MMX/SSE
GL_VERSION    = 1.2 Mesa 3.4.2
GL_VENDOR     = VA Linux Systems, Inc.
GL_EXTENSIONS = GL_ARB_multitexture GL_ARB_transpose_matrix GL_EXT_abgr 
GL_EXT_clip_volume_hint GL_EXT_compiled_vertex_array GL_EXT_histogram 
GL_EXT_packed_pixels GL_EXT_polygon_offset GL_EXT_rescale_normal 
GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_env_add 
GL_EXT_texture_object GL_EXT_texture_lod_bias GL_EXT_vertex_array 
GL_MESA_window_pos GL_MESA_resize_buffers GL_NV_texgen_reflection 
GL_PGI_misc_hints GL_SGIS_pixel_texture GL_SGIS_texture_edge_clamp
3191 frames in 5.0 seconds = 638.200 FPS
3197 frames in 5.0 seconds = 639.400 FPS
3197 frames in 5.0 seconds = 639.400 FPS
3134 frames in 5.0 seconds = 626.800 FPS
3150 frames in 5.0 seconds = 630.000 FPS
3149 frames in 5.0 seconds = 629.800 FPS
3150 frames in 5.0 seconds = 630.000 FPS
3135 frames in 5.0 seconds = 627.000 FPS

is this too slow? any ideas on the crashing GEM with the PLanet CCRMA .rpms?
Where do i add the
#include <string.h>

i would like a clean build of GEM for some work i would like to do


kurt stockman wrote:

>I experienced similar problems with an ATI radeon 7500.
>On debian i managed to overcome them by installing the xlibmesa3, xserver
>and xlibmesa-dev packages from http://people.debian.org/~daenzer/dri-trunk/
>+ compiling radeon.o from the drm-trunk-module sources on that site (he has
>them for i386 and ppc).
>But being a lousy hacker I screwed those up prety fast whilst upgrading some
>other stuff... + i never got the radeon TV-out to work (Gatos and others
>didn't work for me).
>Now I'm on Redhat 8 with the Planet CCRMA packages and low latency kernel. I
>threw out the radeon and got me a relativly cheap nvidia 440 MX. Nvidia
>offers linux drivers on their site >> They were realy easy to compile +
>install (although the dl-ed kernel-package is compiled with 2.95, compiling
>the nvidia drivers and module with 3.2 worked just fine) and give me nice 3d
>support,tv-out and twinview (dual screen / 1 desktop >> pd-patch on my
>monitor + gemwin on the TV-out). info : http://www.sh.nu/nvidia/
>And Gem didn't segfault since...
>hope this helps someone,
>-----Oorspronkelijk bericht-----
>Van: pd-list-admin at iem.kug.ac.at
>[mailto:pd-list-admin at iem.kug.ac.at]Namens zmoelnig at iem.at
>Verzonden: zondag 19 januari 2003 9:45
>Aan: marcell mars
>CC: pd-list at iem.kug.ac.at
>Onderwerp: Re: [PD] Gem failed after compiled against gcc 3.2 on
>hi !
>>i think it is probably radeon module which i successfully installed
>>after some problems.. i remember that it failed on other modules but
>>radeon seemed to go well... donno...
>i agree, that i sounds like the problem is with your drivers.
>well, have you tried the "vesa" module ? it's very generic and works for my
>radeon on my notebook (though, of course, performance is not sufficient)
>PD-list mailing list
>PD-list at iem.kug.ac.at
>PD-list mailing list
>PD-list at iem.kug.ac.at

More information about the Pd-list mailing list