[PD] imagemagick --enable shared

sara kolster sara at x-i.net
Fri Dec 19 14:34:20 CET 2003

Hi Rob,

Haven't installed Imagemagick by source yet, but have a package in my 
machine so i could try. Do you know where this *&(*#$% -library has to 
be installed? ;)
No .dylib on my machine.

Did you get the sourcepackage via the Imagemagick website?


robcanning wrote:

> hi sara,
> hmmm...
> i think i built imagemagick from source with the ./configure 
> --enable-shared flag
> i think the advice about changing the .info file in fink came after i 
> had already built imagemagick.
> to tell the truth, being a newbie to OSX and terminal there maybe bits 
> and pieces of half installed versions of imagemagick all over my 
> machine! i could have installed imagemagick with the --disabled-shared 
> in fink then found out about --enable-shared and then reinstalled from 
> source.
> I checked the .info file for imagemagick in fink and it is indeed 
> intact with the --disable-shared.
> do you have libmagick.dylib files in your /usr/local/lib/folder?
> have you tried to build from source with the ./configure 
> --enable-shared flag?
> ++++++++++++++++++++++++++++++++++++++++++++++++++++
> robcanning
> www.robcanning.utvinternet.com
> On Friday, December 19, 2003, at 10:14  AM, sara kolster wrote:
>> Hi Rob,
>> Can you remember when you were changing the .info file from 
>> Imagemagick, if you did this in the terminal or in Fink. Cause when i 
>> tried this in Fink, it wouldn't let me save the file, but when i did 
>> it in the terminal it was easy to do.
>> I'm just thinking, if you did this via Fink, maybe the file wasn't 
>> saved? So maybe you installed Imagemagick without --enable shared. [I 
>> just try to come up with some 'possibilities']
>> And does anyone know if PDP doesn't run when Imagemagick isn't 
>> installed with --enable shared?
>> Sara
>> robcanning wrote:

More information about the Pd-list mailing list