[PD] [gem] pix_filmNEW troubles on win

IOhannes m zmoelnig zmoelnig at iem.at
Wed Feb 18 09:04:14 CET 2004

leo {depart} wrote:
> hello!
> i've just tried gem-bin0.888pre on winxp (with pd 0.36-0). unfortunately 
> i have problems with pix_film and my movie files now (worked fine with 
> gem0.87+cvs)
> whenever i try to load one of my movies (avi, indeo4/5.1, 512x512px) my 
> pd crashes. when i turn rendering off, before i load the movie file, i 
> get a a decent "pix_filmNEW: loaded... " message. if i turn rendering on 
> then, it crashes.
> - the homer.avi works fine !!, so i guess it could be a codec issue ( 
> has the indeo support been cut? )
> - further it won't accept my relative paths ("unable to find...") that i 
> used so far in my patches...

looks like you are using an older pre-release of gem.
try the one that can be found at 

this should fix the relative-paths issue.
about codecs: of course, the decoding is not done in Gem itself but by 
libraries provided by the system. this does mean, that there is no way 
to "drop support" for a specific codec (this is wrong too: of course a 
check could be done whether a file is encoded with a special codec and 
refuse to decode; but this would be plain malignity)

the issue seems to be more about using quicktime4windows.
i haven't been able to get it really stable when decoding AVI-files 
(MOVs work fine however)
in prior versions (i guess like the one you are using) quicktime4win has 
  been tried prior to the "normal" (microsoft) avi-decoding.
this lead to crashes when trying to load "another" movie (say: you 
loaded a quicktime and *then* wanted to load an avi --> crash) at least 
on my machine.
i have changed the library order, so that microsoft's avi-loader will 
give a first try (and fail on quicktimes), and then quicktime will have 
a look.
however, loading MPEGs crashes fine with me.


More information about the Pd-list mailing list