[PD] Re: Loading PD External

doniguan at stny.rr.com doniguan at stny.rr.com
Thu Mar 18 20:02:53 CET 2004

My Pd.command File has this in it so far

/usr/local/bin/pd -rt 

Im not quite sure how to edit it and still have it be able to execute. I can open it in Textedit, but when i click to run it, i get an error.

Im not sure how to run the pd.command from a terminal. I opened a terminal window and clicked Run command, and typed in Pd, Pd.command, it didnt work. 

I found the directory my .darwin files are in (I assume those are the library's)
/usr/local/lib/pd/extras/ (Thats where xsample.pd.darwin is) And /usr/local/lib/pd/PeRColate/

Im new to unix and this whole thing. On my pc, i could edit batch files like patches, edit them and resave them. But it wont let me do that with my command file.

Thanks- AP


to pass arguments to pd you must either open a shell (aka: DOS-box) 
(with "Start->Execute..." and running "cmd" on "modern" systems) or use 
and edit a .bat-file.
starting pd with simply clicking on the "pd.exe" will not allow you to 
pass arguments.

1. one of the most important flags for pd is the "-verbose" flag; it 
gives a lot of interesting (and mostly uninteresting) information on the 
stderr (which is displayed in the DOS-box)
so the command line would look like "pd.exe -verbose"

2. normally pd tries to search and find unknown objects and libraries on 
several paths, e.g: "/path/to/my/pd/extra";
you can add additional paths with the "-path" flag
such command line would look like "pd.exe -path /path/to/my/libraries/"

3. to load a library use "-lib ", eg "-lib zexy".
this library is searched in the built-in and in the specified (see (2)) 

when trying (and failing) to load a library it will say something like
tried /my/home/asdf.pd_linux and failed
tried /usr/lib/pd/extra/asdf.pd_linux and failed
asdf: can't load library

when trying (and succeeding) to load a library it will probably say
tried /my/home/qwer.dll and failed
tried /usr/lib/pd/extra/qwer.dll and succeeded

so go and have a try:
"pd.exe -verbose -path /path/to/my/percolate/ -lib percolate"

go and figure out what the errors on the shell mean.

a) cases *might* matter
b) avoid spaces in path-names, e.g. "-path C:\Program Files\pd" is a 
*very* bad place to put things in.


More information about the Pd-list mailing list