[PD] New PDP/PiDiP for OSX

sara kolster sara at x-i.net
Wed Mar 24 11:21:36 CET 2004

Hi Yves,

In my pd terminal it sais it can't load the library..
tried /usr/local/lib/pd/pdp_pidip_osx/pdp.pd_darwin and failed
and failed
/usr/local/lib/pd/pdp_pidip_osx/pdp: can't load library

I tried to do 'make', but get the following error:

g++: /sw/src/ffmpeg/libavformat/libavformat.a: No such file or directory
g++: /sw/src/ffmpeg/libavcodec/libavcodec.a: No such file or directory
make: *** [darwin] Error 1

When i do a fink install [of either] libavformat, libavformat.a, 
libavcodec, libavcodec.a it says: no package found.
A fink install ffmpeg isn't neccessary -->  No packages to install.

If i look in Fink i see packages that are called:
[Does this 1 implies another name than the libs where pdp_pidip_osx is 
linked to now?]

Is there something else which needs to happen in order to make it work?



Yves Degoyon wrote:

> yep, should work ( back up the old one )
> as you already have the libs,
> if a lib is missing in the new directory,
> you can try to issue a 'make' to force relinking.
> cheers,
> sevy
> sara kolster wrote:
>> Hi Yves,
>> To avoid difficulties later; i've pd / pdp / pidip running already, 
>> so what would be the best way to install this new PDP/Pidip for OSX?  
>> I assume that i just replace the pdp_pidip_osx folder by the new one, 
>> but i'm not sure.
>> Sara

More information about the Pd-list mailing list