[PD] Mandrake PPC 9.1+PD Installation

ix ix at replic.net
Wed Jul 21 21:37:18 CEST 2004

On Thu, Jul 22, 2004 at 03:06:55AM +0800, slimboyfatboyslim wrote:
> hi,
> I've tried to install 0.37 RPM distribution in Mandrake PPC 9.1 and 
> I've the strange error of PD keeping asking for libtcl.so.0 and 
> libtk.so.0, so I create a symbolic link to tcl8.3 and tk8.3, but it 
> said the package doesn't match the architecture, so I -rpm -i --nodeps 
> --ignorearch pd....rpm, I've installed the files under /usr/lib but 
> when I typed pd, it said can't execute binary.
> I've also tried to compile the source by myself and it said it doesn't 
> match the architecture and there's error for the port audio when I make 
> install.
> Anyone try to install PD under Mandrake PPC 9.1 with PB 15'' 1 Gz, ATI 
> radeon 8500 successfully?

sounds like you got an x86 or maybe OSX package somehow. try this:
first download tcl & tk 8.5, & puredata source.tar.gz,,

cd tcl/unix; ./configure; make; make install; cd ../../tk/unix; ./configure --enable-xft; make; make install; apt-get install alsa-headers libasound2-dev libjack0.80.0-dev; cd ../../pd/src; autoconf; ./configure; make; make install; grep local/lib /etc/ld.so.conf || echo "/usr/local/lib" >> /etc/ld.so.conf; ldconfig

usually i can paste the above, walk away and come back in 5 minutes its done, on debian-ppc (or x86).you may have to change the part about grabbing the alsa/jack headers for mandrake...good luck!

More information about the Pd-list mailing list