[PD] Gem compile problems

Ian Smith-Heisters heisters at 0x09.com
Sun Jul 25 05:48:30 CEST 2004


I'm also having some problems compiling Gem. I've tried both the CVS 
version and the .90 release. ./configure keeps resulting in this:

building pix_filmFFMPEG
checking for dv_init in -ldv... no
checking alternate -ldv in ../../../GemLibs/ /usr/local/lib 
/usr/local/src... configure: error: library dv not available - try 

I've run makeauxlibs and it finishes successfully. I ran configure with 
these options:

./configure --prefix=$HOME --libdir=/usr/lib 
--includedir=usr/lib:../../../GemLibs:/usr/include --enable-mmx 
--with-ftgl --with-mpeg --with-mpeg3 --with-quicktime --with-avi 
--with-ieee1394 --with-x

because /usr/lib has libdv.a .la .so .so.2 .so.2.1.0 .so.4 .so.4.0.0. 
Since using the modified includedir and libdir didn't seem to change 
anything I tried editing the configure file, replacing every instance of 
/usr/local/lib with /usr/lib, but that still doesn't change anything.

Thank you for any help.

-Ian SMith-Heisters

More information about the Pd-list mailing list