[PD] Gem compile problems

Ian Smith-Heisters heisters at 0x09.com
Mon Jul 26 01:51:00 CEST 2004

guenter geiger wrote:

>If you are on Debian, you should always try the Debian package first,
>this should keep you out of all the compilation trouble.
>If you are not happy with the precompiled version (it doesn't have
>avi support, because libavifile is not cross platform) let me
>know. I will do my best to make good packages. As long as noboy complains
>I assume the packages are working perfectly.
>If you want to compile gem by hand, Debian offers you some help for
>finding the correct libraries.
># apt-get build-dep gem

I'm compiling by hand (despite the headache) for features and control. I 
used to have the debian packages installed and found it difficult to 
install new externals that are only available in source. Having 
everything compiled by hand makes updates easier in the long run for me. 
I generally only use apt-get for every day packages, ones that I really 
count on and use a lot (like PD) I do by hand. I've never used apt-get's 
source management though, I've only used it to install binaries.

apt-get build-dep gem tried to install the puredata package, while I'm 
trying to install this all with a hand compiled devel_0_37 cvs pure data.

I suppose I may be doing things backwards, but it works now, so oh well.

Another thing is that I'm running Sarge, not SID, so my addiction to 
features wouldn't be fed unless I used CVS versions for my favorite 

And one last thing is that I'm gearing up to start writing some C stuff 
to work with PD, so I'm going to want all the latest sources.


>will install all the libraries you need to compile gem.
>(you have to install libavifile-dev by hand, though)
># apt-get install libavifile-dev
>Then compile gem either the standard way, or automatically
># apt-get source --build gem
>On Sat, 24 Jul 2004, Ian Smith-Heisters wrote:
>>I'm also having some problems compiling Gem. I've tried both the CVS
>>version and the .90 release. ./configure keeps resulting in this:
>>building pix_filmFFMPEG
>>checking for dv_init in -ldv... no
>>checking alternate -ldv in ../../../GemLibs/ /usr/local/lib
>>/usr/local/src... configure: error: library dv not available - try
>>I've run makeauxlibs and it finishes successfully. I ran configure with
>>these options:
>>./configure --prefix=$HOME --libdir=/usr/lib
>>--includedir=usr/lib:../../../GemLibs:/usr/include --enable-mmx
>>--with-ftgl --with-mpeg --with-mpeg3 --with-quicktime --with-avi
>>--with-ieee1394 --with-x
>>because /usr/lib has libdv.a .la .so .so.2 .so.2.1.0 .so.4 .so.4.0.0.
>>Since using the modified includedir and libdir didn't seem to change
>>anything I tried editing the configure file, replacing every instance of
>>/usr/local/lib with /usr/lib, but that still doesn't change anything.
>>Thank you for any help.
>>-Ian SMith-Heisters
>>PD-list mailing list
>>PD-list at iem.at
>>to manage your subscription (including un-subscription) see
>PD-list mailing list
>PD-list at iem.at
>to manage your subscription (including un-subscription) see

More information about the Pd-list mailing list