[PD] pdp mac os X

james tittle tigital at mac.com
Wed Nov 10 20:32:45 CET 2004

On Nov 9, 2004, at 5:22 AM, Gonzague DDR wrote:

> Hi list ,
> I ve just installed pd 0.37.0 on a mac osX , and i
> never touch a mac before .

...that's ok, they don't bite...

> I have little trouble with gem : all seams to work
> very well ( loading gem , creating gem objects ,
> video_pix is working ), but the [gemmouse] do not
> return any value ...?

...what version of gem are you using?  If you are using cvs or 0.90, 
then you can input via [gemmouse] using a little trick:  hold down the 
"open-apple"/command key when trying to track the mouse...this extra 
key press is necessary because, atm, the gem window runs in pd, which 
isn't doing the right things to get the aqua window manager to allow it 
to behave as a regular window...this is being worked on, but isn't 

> An other thing is that , when i run pd -lib pdp ,it
> find pdp.pd-darwin , but crash saying :
> dyld: /usr/local/bin/pd can't open library:
> /sw/lib/libgsl.0.dylib  (No such file or directory,
> errno = 2)
> Do someone have an idea ?

...sure, you don't have libgsl.0.dylib installed...so you have two 
choices:  one would be to compile & install all of the pdp dependencies 
via fink (gsl, dlcompat-shlibs, readline at least), or the other is to 
grab the copy that has this all done for you, and then place the libs 
where they need to go...


More information about the Pd-list mailing list