[PD] VERY strange OSX PDP install problem

derek holzer derek at x-i.net
Mon Mar 7 13:02:33 CET 2005

Dear PD-listers,

This might not be the first time I've said it, but I SWEAR I'm not 
crazy!!! ;-)

Here's the deal: I've been sucessfully installing PDP for OSX 10.3+ 
users now for over a half a year using these instructions:


Essentially, install the Mac developers tools, then X11User package, 
TclTkAqua-8.4.4 and PureData-0.37.1_MacOSX-(0.2.5)-TclTk8.4, followed by 
unpacking the pdp_pidip_osx.tar.gz in the / directory.

On every machine I've installed on in Europe, this is sufficient.

However, on every machine I've tried it on the last couple months in the 
US, it doesn't work! Here's the error, consistant every time:

dyld: /usr/local/bin/pd can't open library: /sw/lib/libdl.0.dylib  (No 
such file or directory, errno = 2)
pd_gui: pd process exited
Trace/BPT trap

Is there something different about American Macs that I need to know!?! 
All US machines in question were OSX 10.3.7 or 10.3.8, to the best of my 
knowledge. Is it possible that something got dropped by Apple in the 
latest 10.3 versions?

And, of course, how to fix? I assume that installing "dlcompat" with 
Fink would fix it, but that is really another big step in an 
already-complicated install process that leaves most Mac folks bewildered!

CC'd above are a couple "test cases" that haven't worked out yet. Please 
include them in all replies. Thx!


derek holzer ::: http://www.umatic.nl
---Oblique Strategy # 36:
"Consult other sources

More information about the Pd-list mailing list