[PD] Re: Gridflow install issue...

Mathieu Bouchard matju at sympatico.ca
Sat Mar 26 09:12:38 CET 2005

On Fri, 25 Mar 2005, vze26m98 wrote:

> cturner at vatic:/usr/local/src/gridflow$ make
> ruby -w base/source_filter.rb base/grid.h base/grid.h.fcs
> make: ruby: Command not found
> make: *** [base/grid.h.fcs] Error 127
> My Ruby executable is named ruby1.8, which the makefile seems to get:
> ruby = /usr/bin/ruby1.8
> Any ideas?

GridFlow indeed assumes it would be named "ruby". sorry. I just fixed it
in the cvs head.

I have a question for you: how should be handled the situation that an
executable ruby source file starts with the line "#!/usr/bin/env ruby" ?

On Fri, 25 Mar 2005, vze26m98 wrote:

> OK- hardwiring the ruby invocations as 'ruby1.8' in the Makefile got
> everything running.  The invocation generates the follwoing error
> repeatedly, causing the make to fail eventually:
> base/source_filter.rb:38: warning: regexp has invalid interval

This is only a warning. It is benign (and i fixed it a long time ago in
the cvs head). The error you are having has to be something else than

Mathieu Bouchard -=- Montréal QC Canada -=- http://artengine.ca/matju

More information about the Pd-list mailing list