[PD] pix_video odyssey: no method on 2 systems

Ian Smith-Heisters heisters at 0x09.com
Thu Mar 31 09:19:40 CEST 2005

I've been trying to get pix_video working satisfactorily on a number of 
systems, and have finally settled on using a G4 PowerBook. I've never 
really used Mac OSX beyond some basic network and programming stuff, so 
bear with me please.

I downloaded the pd 0.38-3 app from 
http://pcm.peabody.jhu.edu/~sburt/pd/installing_pd_os_x.html, it loaded 
Gem 0.90 without error.

When I send [open 0( [device 0( [driver 0( [enumerate( or any other 
methods besides [dim( I get

pix_videoDarwin: no method for 'open'

...or whatever method I tried. I found this problem in the archives in 
2003, but renaming pix_video to pix_videoDarwin, as suggested, didn't 
help anything.

I got the same error with Hans-Christoph Steiner's installer and a 
manual installation from SF.net. I also got a similar error trying 
DeMuDi 1.1.1 on another computer.

What gives? Am I doing something just utterly stupid? Thanks for any 
help you can offer.



More information about the Pd-list mailing list