[PD] pix_video odyssey: no method on 2 systems

B. Bogart ben at ekran.org
Thu Mar 31 15:58:17 CEST 2005

Hey Ian,

I assume since your messing with open messages that pix_video does not
find your device automatically? You could try sending the "reset" message.

I think in early versions of gem for OSX pix_video only supported
fire-wire input (maybe still) is that what your using? (I guess so since
your on a PB)

1. Connect and Turn on camera
2. quick ichat or whatever else OSX runs when a camera turns on
3. create pix_video object, open patch, or send "reset" to pix_video.

Then it should work. Some cameras are weird with outputting firewire
while using analog input....

Hope that helps/


Ian Smith-Heisters wrote:
> I've been trying to get pix_video working satisfactorily on a number of
> systems, and have finally settled on using a G4 PowerBook. I've never
> really used Mac OSX beyond some basic network and programming stuff, so
> bear with me please.
> I downloaded the pd 0.38-3 app from
> http://pcm.peabody.jhu.edu/~sburt/pd/installing_pd_os_x.html, it loaded
> Gem 0.90 without error.
> When I send [open 0( [device 0( [driver 0( [enumerate( or any other
> methods besides [dim( I get
> pix_videoDarwin: no method for 'open'
> ...or whatever method I tried. I found this problem in the archives in
> 2003, but renaming pix_video to pix_videoDarwin, as suggested, didn't
> help anything.
> I got the same error with Hans-Christoph Steiner's installer and a
> manual installation from SF.net. I also got a similar error trying
> DeMuDi 1.1.1 on another computer.
> What gives? Am I doing something just utterly stupid? Thanks for any
> help you can offer.
> -Ian
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 256 bytes
Desc: OpenPGP digital signature
URL: <http://lists.puredata.info/pipermail/pd-list/attachments/20050331/e7f96634/attachment.pgp>

More information about the Pd-list mailing list